$re = '/((?:^|\n|;)\s*)export(.+)(?:as)?(\s*)default/s';
$str = 'export const test = \'\';
@Component
export class Foo {
/*default*
/}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);