$re = '/(?P<start>Hello, I have)(?P<middle>.+?)(?P<end>car)/m';
$str = 'Hello, I have a very expensive car';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);