using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^=separator=.*(?:\R(?!(?:=separator=|.*?\bunwantedKeyword\b)).*)*\R.*?\bunwantedKeyword\b.*\R*";
string substitution = @"";
string input = @"=separator=
data
unwantedKeyword
data
=separator=
data
wantedKeyword
data
=separator=
data
unwantedKeyword
data
=separator=
data
wantedKeyword
data
=separator=";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}