const regex = /^=separator=.*(?:\R(?!(?:=separator=|.*?\bunwantedKeyword\b)).*)*\R.*?\bunwantedKeyword\b.*\R*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^=separator=.*(?:\\R(?!(?:=separator=|.*?\\bunwantedKeyword\\b)).*)*\\R.*?\\bunwantedKeyword\\b.*\\R*', 'gm')
const str = `=separator=
data
unwantedKeyword
data
=separator=
data
wantedKeyword
data
=separator=
data
unwantedKeyword
data
=separator=
data
wantedKeyword
data
=separator=`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);