#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!<div>)(.*)$"
Local $sString = "<div>Lorem ipsum.</div> - эту строку не надо;" & @CRLF & _
"Lorem ipsum. - эту строку надо;" & @CRLF & _
"<li>Lorem ipsum.</li> - и эту строку надо;" & @CRLF & _
"<div>Lorem ipsum.</div> - эту не надо."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")