const regex = /^(?!<div>)(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!<div>)(.*)$', 'gm')
const str = `<div>Lorem ipsum.</div> - эту строку не надо;
Lorem ipsum. - эту строку надо;
<li>Lorem ipsum.</li> - и эту строку надо;
<div>Lorem ipsum.</div> - эту не надо.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}