# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*\K(?>(?<=school of )\w+|\b\w++(?= school))/[X]/ig;t' <<< "Engineering School
Medical school
The School of Science
High School of science
"