const regex = /.*\K(?>(?<=school of )\w+|\b\w++(?= school))/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\K(?>(?<=school of )\\w+|\\b\\w++(?= school))', 'ig')
const str = `Engineering School
Medical school
The School of Science
High School of science
`;
const subst = `[X]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);