# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*\K(?>(?<=school of )\w+|\b\w++(?= school))"
test_str = ("Engineering School\n"
"Medical school\n"
"The School of Science\n"
"High School of science\n")
subst = "[X]"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.