import Foundation
let pattern = #".*\K(?>(?<=school of )\w+|\b\w++(?= school))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
Engineering School
Medical school
The School of Science
High School of science
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[X]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)