#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "PV1\|(?:[^\|]*\|){18}1703000105\|(?:[^\|]*\|){31}CO"
Local $sString = "MSH|^~\&|SUNNY|SHSC|OACIS|SHSC|20210710161803||ORU^R01|SC20210710161803|P|2.3" & @CRLF & _
"PID|||7030389||Smith^John||20001010|M" & @CRLF & _
"PV1||I|||||||||||||||||1703000123|||||||||||||||||||||||||||||||" & @CRLF & _
"ORC|NW||||||||20210710161803" & @CRLF & _
"OBR|||SCVITALS-202107101618037402|SME^SunnyCare Manual Entry|||20210710010005|||~|||||||||||||||F" & @CRLF & _
"OBX|1|NM|0002-F828^SpRR||24|rpm|||||F|||20210710010005|||MANUAL" & @CRLF & _
"MSH|^~\&|SUNNY|SHSC|OACIS|SHSC|20210710161803||ORU^R01|SC20210710161803|P|2.3" & @CRLF & _
"PID|||7030389||Smith^John||20001010|M" & @CRLF & _
"PV1||I|||||||||||||||||1703000105|||||||||||||||||||||||||||||||" & @CRLF & _
"ORC|CO||||||||20210710161803" & @CRLF & _
"OBR|||SCVITALS-202107101618037402|SME^SunnyCare Manual Entry|||20210710010005|||~|||||||||||||||F" & @CRLF & _
"OBX|1|NM|0002-F828^SpRR||24|rpm|||||F|||20210710010005|||MANUAL" & @CRLF & _
"MSH|^~\&|SUNNY|SHSC|OACIS|SHSC|20210710161803||ORU^R01|SC20210710161803|P|2.3" & @CRLF & _
"PID|||7030389||Smith^John||20001010|M" & @CRLF & _
"PV1||I|||||||||||||||||1703000456|||||||||||||||||||||||||||||||" & @CRLF & _
"ORC|NW||||||||20210710161803" & @CRLF & _
"OBR|||SCVITALS-202107101618037402|SME^SunnyCare Manual Entry|||20210710010005|||~|||||||||||||||F" & @CRLF & _
"OBX|1|NM|0002-F828^SpRR||24|rpm|||||F|||20210710010005|||MANUAL" & @CRLF & _
"MSH|^~\&|SUNNY|SHSC|OACIS|SHSC|20210710165010||ORU^R01|SC20210710165010|P|2.3" & @CRLF & _
"PID|||7030389||Smith^John||20001010|M" & @CRLF & _
"PV1||I|||||||||||||||||1703000105|||||||||||||||||||||||||||||||" & @CRLF & _
"ORC|NW||||||||20210710165010" & @CRLF & _
"OBR|||SCVITALS-202107101650108370|SME^SunnyCare Manual Entry|||20210710110005|||anpatel~anpatel|||||||||||||||F" & @CRLF & _
"OBX|1|NM|0002-F828^SpRR||34|rpm|||||F|||20210710110005|||MANUAL" & @CRLF & _
"MSH|^~\&|SUNNY|SHSC|OACIS|SHSC|20210710165442||ORU^R01|SC20210710165442|P|2.3" & @CRLF & _
"PID|||7030389||Smith^John||20001010|M" & @CRLF & _
"PV1||I|||||||||||||||||1703000105|||||||||||||||||||||||||||||||" & @CRLF & _
"ORC|CO" & @CRLF & _
"OBR|||SCVITALS-202107101643353582|SME^SunnyCare Manual Entry|||20210710165442|||anpatel|||||||||||||||F" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")