using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<form[^>]*name=""loginForm""[^>]*>[^~]*?<\/form>";
string input = @"<html>
<body>
<form method = ""post"" name=""loginForm"" >
<input type=""text"" name=""firstName""/>
<input type=""text"" name=""lastName""/>
</form>
<form method = ""post"" name=""signupForm"" >
<input type=""text"" name=""userName""/>
</form>
</body>
</html>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}