const regex = /<form[^>]*name="loginForm"[^>]*>[^~]*?<\/form>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<form[^>]*name="loginForm"[^>]*>[^~]*?<\\\/form>', 'gm')
const str = `<html>
<body>
<form method = "post" name="loginForm" >
<input type="text" name="firstName"/>
<input type="text" name="lastName"/>
</form>
<form method = "post" name="signupForm" >
<input type="text" name="userName"/>
</form>
</body>
</html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}