using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(?:""([^""]*)""|([^,""<>]*))?\s*(?:(?:,|<|\s+|^)([^<@\s,]+@[^>@\s,]+)>?)\s*";
string input = @"Test1 <test1@x.com>, Test Two test2@x.y.com,T e s t 3 <test3@z.com>, Test@4 <test4@abc.com>, test5@cde.com,
""Bob Smith"" <bob@company.com>, joe@company.com, ""John Doe""<john@company.com>, Billy Doe<billy@company.com>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}