import Foundation
let pattern = #"\s+(?=[A-Z])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"123123 123 A123"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)