use strict;
my $str = '123123 123 A123';
my $regex = qr/^.*\S\K\s+/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";