$re = '/(?<=key=).*?(?=&|$)/m';
$str = 'https://www.example.com/demo/#!/~/signIn/key=RtS1OMW9Tn2q&returnUrl=account/favorites';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);