use strict;
my $str = 'match on specific character, multiple times but not necessarily consecutive
I\'m looking for a \'non consecutive\' way to do something similar to how`{n}` works. Some examples, using the letter `L` , and using `L{2}` *incorrectly* just to demonstrate the desired outcome
LLAMA - match
SHELLS - match
LEVEL \\- match, even though the L\'s are not consecutive
LOSER - no match number of L != 2
LEVELLED - no match, number of L != 2
';
my $regex = qr/\b(?:[^L\W]*L){2}[^L\W]*\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}