# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?:[^L\W]*L){2}[^L\W]*\b"
test_str = ("match on specific character, multiple times but not necessarily consecutive\n\n"
"I'm looking for a 'non consecutive' way to do something similar to how`{n}` works. Some examples, using the letter `L` , and using `L{2}` *incorrectly* just to demonstrate the desired outcome\n\n"
"LLAMA - match\n\n"
"SHELLS - match\n\n"
"LEVEL \\- match, even though the L's are not consecutive\n\n"
"LOSER - no match number of L != 2\n\n"
"LEVELLED - no match, number of L != 2 \n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.