using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^a-zA-Z]*)([a-z])|(\.\s*)([a-z])";
string substitution = @"$1\U$2$3\U$4";
string input = @".this sentence
and this
This is already
.this sentence
and this.also this. and this.This one is not.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}