const regex = /^([^a-zA-Z]*)([a-z])|(\.\s*)([a-z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^a-zA-Z]*)([a-z])|(\\.\\s*)([a-z])', 'gm')
const str = `.this sentence
and this
This is already
.this sentence
and this.also this. and this.This one is not.`;
const subst = `$1\U$2$3\U$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);