// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^a-zA-Z]*)([a-z])|(\.\s*)([a-z])").unwrap();
let string = ".this sentence
and this
This is already
.this sentence
and this.also this. and this.This one is not.";
let substitution = "$1\\U$2$3\\U$4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}