re = /\"externalLinks\"[\s\S]+?(?=\"maxPop\")/m
str = '"oge": "GOF",
"original": {
"report": true,
"tier": "IA"
},
"pertinentNegative": false,
"populationFrequency": {
"externalLinks": {
"7-2-A-T": "https://x.d.org/s/7-d-A-T?dataset=s"
},
"maxPop": "South Asian",
"maxPopAC": 1,
"maxPopAN": 30,
"maxPopFreq": 3.276,
"overallPopAC": 1,
"overallPopAN": 23,
"overallPopFreq": 4.22,
"source": "gnomAD"
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end