import Foundation
let pattern = #"(?:[BR]?|(?<!L)C)REF|^(?!\|)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
XYZ:MUMBAI UNIVERSITYCREF:PUNE UNIVERSITYBREF:DADAR UNIVERSITYRREF:KOLHAPUR UNIVERCITY LLCREF:SOLAPUR UNIVERSITY
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"|\g<0>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)