# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*?)(fieldid=)*(')*(\d*)(')*"
test_str = ("blah blah fieldid='123456'\n"
"blah blah\n"
"blah blah fieldid='123457'\n"
"blah\n"
"blah blah fieldid='123458'")
subst = "$4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.