// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*?)(fieldid=)*(')*(\d*)(')*").unwrap();
let string = "blah blah fieldid='123456'
blah blah
blah blah fieldid='123457'
blah
blah blah fieldid='123458'";
let substitution = "$4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}