using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(-?)([1-4]{1})([0-9]{6})\b";
string input = @"991111-2111111";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}