package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(-?)([1-4]{1})([0-9]{6})\b`)
var str = `991111-2111111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}