// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^").unwrap();
let string = "shoot_0001.jpg
shoot_0002.jpg
shoot_0003.jpg
shoot_0004.jpg
shoot_0005.jpg
shoot_0006.jpg
shoot_0007.jpg
shoot_0008.jpg
shoot_0009.jpg
shoot_0010.jpg";
let substitution = "title_";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}