package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[.+\]\(https?:\/\/.+\.\w{2,}\)`)
var str = `[h](https://yande.dev)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}