use strict;
my $str = '<!DOCTYPE html>
<html>
<head>
<link href=\'http://fonts.googleapis.com/css?family=Raleway:400,700\' rel=\'stylesheet\' type=\'text/css\'>
<link href=\'http://fonts.googleapis.com/css?family=Open+Sans+Condensed:700\' rel=\'stylesheet\' type=\'text/css\'>
<link href="https://maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css" rel="stylesheet">
<link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.1/css/bootstrap.min.css">
<link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.1/css/bootstrap-theme.min.css">
<link rel="stylesheet" type="text/css" href="http://www.text.ru/css/style.css?v=58539">
<link rel="stylesheet" type="text/css" href="http://www.text.ru/css/responsive.css?v=28967">
<title>Afla ce iti doreste AppLine !</title>
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta content="width=device-width, initial-scale=1" name="viewport">
<meta property="og:title" content="text!"/>
<meta property="og:type" content="website"/>
<meta property="og:description" content="text !"/>
<meta property="og:image" content="http://www.example.ro/images/ex/0166627d.png" />
HERE;';
my $regex = qr/<meta.*og:image.*?(http:\/\/.*?)"\s+\/>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}