use strict;
my $str = 'show configuration
[?1h=
interfaces {[m
ethernet eth1 {[m
duplex auto[m
address 172.22.108.100/24[m
speed auto[m
smp_affinity auto[m
}[m
loopback lo {[m
}[m
}[m
system {[m
time-zone UTC[m
syslog {[m
}[m
config-management {[m
commit-revisions 20[m
}[m
host-name dm2500[m
[m
BLABLABLA
[K[?1l>admin@dm2500:~$ ';
my $regex = qr/(\x1B7)?(\x9B|\x1B\[)[0-?]*[ -\/]*[@-~](\x1B[=>]\r?)*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}