const regex = new RegExp('(?!.*([IXCM])(\\1{3}))(?!.*([VLD])(\\3))^[IVXLCDM]+$', '')
const str = `VIIIIIII`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}