use strict;
my $str = '0989914009 nguyeng quangthang0989914009 thang 9301234567898 123 01201234567892 0989914009 nguyeng quang nn thang +84989914009
nmv nguyeng quang thang0989914009';
my $regex = qr/([a-zA-Z]|\s|^)((\+84|0)(1[2689]|9)+[0-9]{8})([a-zA-Z]|\s|$)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}