import Foundation
let pattern = #"([a-zA-Z]|\s|^)((\+84|0)(1[2689]|9)+[0-9]{8})([a-zA-Z]|\s|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
0989914009 nguyeng quangthang0989914009 thang 9301234567898 123 01201234567892 0989914009 nguyeng quang nn thang +84989914009
nmv nguyeng quang thang0989914009
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)