$re = '/#\s*Person(\n|.)+(?=#\s*Pet)/m';
$str = '# Person
---
Name: Nick King
Age: 18
Speech: "Hello!! How are you? Me & you are different. I\'m the #1"
# Pet = Dog
---
Name: Bill
# Pet = Cat
---
Name: Zacky
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);