package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^0-9]+)(\.)([0-9]+)(B)([0-9]+)(\.)([^0-9]+)(\.)(.+)`)
var str = `abcd.1B21.efg.hi.txt `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}