$re = '/<a[^>]*([^"]*)[^>]*>([ 0-9a-zA-Z]+)<\/a>/';
$str = '<a href="http://fonini.github.io">Jonnas Fonini</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);