# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[^<]?(https?:\\/\\/(www\.)?[-a-zA-Z0-9@:%._\+~#=]{1,256}\.[a-zA-Z0-9()]{1,6}\b([-a-zA-Z0-9()@:%_\+.~#?&\\/\\/=]*))[^>]?$/<$1>/gm;t' <<< "https://www.google.com/
https://www.fakesite.co.in
https://www.fakesite.co.uk
<https://www.fakesite.co.uk>
<https://www.google.com/>"