const regex = new RegExp('"(\\w+)"(?=:)', 'gm')
const str = `["key": val, "key2": val, "key3": v, "key5": 34, "key6": "ef"]`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);