use strict;
my $str = '["key": val, "key2": val, "key3": v, "key5": 34, "key6": "ef"]';
my $regex = qr/"(\w+)"(?=:)/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";