const regex = /(https:\/\/www\.youtube\.com\/.*?)(?:\s|$)|(https:\/\/youtu\.be\/.*?)(?:\s|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https:\\\/\\\/www\\.youtube\\.com\\\/.*?)(?:\\s|$)|(https:\\\/\\\/youtu\\.be\\\/.*?)(?:\\s|$)', 'g')
const str = `https://www.youtube.com/watch?v=<video_id> test https://youtu.be/<video_id testasd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}