$re = '/(?:(?![aeiou])[a-z]){2,4}/m';
$str = 'abcdef';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);