$re = '/^(?![#\/.]).*(?<![#\/.])$/m';
$str = 'abcdef
/fooo
foobar/
/foobar/
hash#in the middle
foo.bar
#hashtag
blah.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);