use strict;
my $str = '( rafa / %aa)+(23+34)';
my $regex = qr/(\([^\(]*\))/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";