use strict;
my $str = 'A scripture reference like [Luke 2:12, 16](accord://read/?Luke 2:12, 16) should be clickable.';
my $regex = qr/(?:\baccord\b|\G(?<!^))[^)\s]*\K\s+/mp;
my $subst = '%20';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";