#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^{\R\h{2,}label:\h+"[^"\\]*(?:\\.[^"\\]*)*",\R\h{2,}value:\h+"[^"\\]*(?:\\.[^"\\]*)*",\R},"
Local $sString = "{" & @CRLF & _
" label: "Other"," & @CRLF & _
" value: "Other"," & @CRLF & _
"}," & @CRLF & _
"" & @CRLF & _
"{" & @CRLF & _
" label: "this is \" a test"," & @CRLF & _
" value: "1234"," & @CRLF & _
"},"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)