$re = '/^{\R\h{2,}label:\h+"[^"\\\\]*(?:\\\\.[^"\\\\]*)*",\R\h{2,}value:\h+"[^"\\\\]*(?:\\\\.[^"\\\\]*)*",\R},/m';
$str = '{
label: "Other",
value: "Other",
},
{
label: "this is \\" a test",
value: "1234",
},';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;