package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[ äÄöÖüÜa-zA-Z0-9-_.,\'"^&+° #!?@$]+$`)
var str = `avf# ä!+Ä$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}