re = /\|[^|]*\|\S\s/m
str = 'from |cffa22fc8Peachee|r others'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result